Справочник по плагинам для кросс-браузерного HTML5

в 2:43, , рубрики: html, html5, Веб-разработка, старые браузеры, метки: , ,

image
Авторы Modernizr решили собрать в одном большом, гигантском справочнике все прослойки, fallback-и и polyfill-ы, которые помогут обеспечить функциональность html5 в тех браузерах, где он не поддерживается

Общая идея такова: мы, как разработчики, должны разрабатывать с применением HTML5 API. Разработка с учетом прицела на будущее позволяет поддерживать не особо устаревшие браузеры, но при этом, если пользователь обновился, он получит поддержку уже на уровне браузера, а не с помощью сторонних плагинов.

Как определить, поддерживает ли браузер ту или иную функцию? Modernizr! Как написать свой polyfill? Есть мануал (на английском) Пишем polyfill-ы на JS для кросс-браузерности

Справочник доступен в виде страницы на Github.

PS: я начал его переводить, но потом заметил, что большая часть текста (названия, авторы) все равно на английском, да и текста там немного, так что, думается мне, особых проблем при чтении не возникнет

Автор: theaqua

Поделиться

* - обязательные к заполнению поля