Добавлена поддержка «Яндекс.Карты» версии 2.1 в angular.js модуль yaMap

в 8:41, , рубрики: AngularJS, javascript, yandex map api, yandex maps, яндекс, метки: , , ,

После публикации статьи «Яндекс.Карты для angular.js утекло немало воды, а также появились новые возможности. В настоящий момент в модуль angular.js для использования карт „Яндекса“ на ваших страницах добавлена поддержка версии 2.1 yandex map api. Не скажу, что суть модуля сильно поменялась, но все же некоторые изменения были внесены. Хотите знать какие, добро пожаловать под кат.

Основные изменения:

  1. Исчезла директива ya-toolbar за ненадобностью. Вместо нее теперь используется атрибут ya-controls директивы ya-map для задания стандартных элементов управления. Также никто не отменял использование директивы ya-control для создания собственных элементов управления.
  2. yaMapSettings теперь представлен провайдером, что позволяет задать настройки в блоке config до старта приложения
  3. Добавлена директива ya-dragger, которая представляет собой перетаскиваемый на карту элемент управления.

Все остальные изменения ни коем образом не отразились на клиентском api.

Кроме вышеперечисленных изменений были изменены и доработаны существующие примеры.

Проект на github.

На этом разрешите откланяться.

P.S. Буду рад конструктивным замечаниям и критике.

Автор: Tulov_Alex

Источник

Поделиться