H3C: Производительный коммутатор с пол-пинка

в 9:33, , рубрики: switch, Сетевое оборудование, Сетевые технологии, сети для самых маленьких, системное администрирование, метки: ,

H3C: Производительный коммутатор с пол пинкаВ содружестве HP и 3Com родилось аббревиатурное имя для активного сетевого оборудования — H3C. В золотой середине из гигабитной линейки коммутаторов производителя оказался H3C S5120SI.
Не смотря на подробное и захватывающее чтиво User Guide и Command Reference в объеме 800 страниц каждая, настройку и управление можно уложить в 4 листа, доступно для обывателя.
Советы по первичной настройке, под катом.

Установка и ввод в эксплуатацию

Все действия по конфигурированию коммутатора предполагают прямое, активное подключение к консольному порту. Подключение на примере ОС Linux:

sudo apt-get install minicom
dmesg |grep tty узнать соотв-ее устройство COM-порт, напр. ttyS0
sudo minicom -s //указать порт /dev/ttySX, скорость 9600 8N1
sudo minicom

Для нового либо поднятого со склада коммутатора необходимо обнулить конфигурацию.

reset saved-configuration
reboot

Базовая конфигурация это — имя устройства, баннер, интерфейс администрирования и пароль, актуальные дата и время(обязательно чтоб ориентироваться в логах).

sysname %hostname%
undo copyright-info enable
undo ip http enable //убираем шелуху
vlan %NUM%
description vlan_Managment
name vlan_Managment
interface vlan-interface %NUM%
ip address %SWITCH_IP% 255.255.255.0
ip route-static 0.0.0.0 0.0.0.0 %GW_IP%
ntp-service unicast-server 217.71.128.77 //сервер времени страта-2, НГТУ
clock timezone NOVT add 07:00:00 //актуальный часовой пояс
super password cipher %PWD_super%
user-interface aux 0
authentication-mode password
set authentication password cipher %PWD_AUX%
telnet server enable
user-interface vty 0 4
authentication-mode scheme
local-user %USER%
password cipher %PWD%
service-type telnet
user-interface vty 5 15
authentication-mode password
set authentication password cipher %PWD_recovery% //используется пароль на случай отказа схемы и домена авторизации.

Домен авторизации

Для использования единых аккаунтов администрирования на группе коммутаторов логин-пароль можно хранить на сервере RADIUS.
Таблица radcheck в базе данных RADIUS:

username, attribute, op, value:
%user%, Cleartext-Password, :=, %password%

В таблице radgroupreply добавляются записи с именем группы и устанавливаются значения Service-Type = Administrative-User и Acct-Status-Type = Accounting-On. Пользователь добавляется в соответствующую группу в таблице radusergroup:

username, groupname, priority:
%user%, %group%, 1

Разрешить подключение к RADIUS и указать ключ обмена необходимо в файле clients.conf:

client %SWITCH_NET%/24 {
secret
= %KEY%
shortname = h3c
}

На коммутаторе необходимо настроить схему для соединения с сервером авторизации:

radius scheme %scheme_name%
primary authentication %IP_RADIUS%
primary accounting %IP_RADIUS%
key authentication %KEY%
key accounting %KEY%
user-name-format without-domain

Настройка домена позволяет входить используя учетные записи local-user и RADIUS сервера.

domain %domain_name%
authentication login radius-scheme %scheme_name%
authorization login radius-scheme %scheme_name%
accounting login radius-scheme %scheme_name%
access-limit disable
state active
idle-cut disable
self-service-url disable
domain default enable %domain_name%

Multiple Spanning Tree Protocol

Управляющий протокол уровня Layer 2 MSTP позволяет создавать избыточные соединения между коммутаторами, не образуя петли. Указанный для случая (instance, 0 — по умолчанию) корневой свитч поддерживает все соединения в режиме передачи (designated, forwarding), а подключенные ниже свитчи определяют ближайший порт к корню и активируют их (root, forwarding), остальные порты во избежании петли блокируются (alte, discarding). Опытным путем определено — после пропажи линка на корневой свитч разблокируется второй линк и передача данных возобновляется менее чем за 1сек. MSTP позволяет строить не зависимые деревья для каждого случая (включающих один или несколько вланов).

[DeviceD] display stp brief 
MSTID Port Role STP State Protection 
0 GigabitEthernet1/0/1 ROOT FORWARDING NONE 
0 GigabitEthernet1/0/2 ALTE DISCARDING NONE 

Пример стенда включает в себя три коммутатора и один общедоступный vlan:
H3C: Производительный коммутатор с пол пинка

interface Vlan-interface %vlan_num%
ip address %IP_switch% 255.255.255.0
stp region-configuration
region-name %region_name%
instance 1 vlan %vlan_num%
active region-configuration
stp enable

Для корневого коммутатора необходимо установить приоритет:

stp instance 1 root primary

Порты 17, 18 включены для доступа и не обмениваются пакетами STP:

interface GigabitEthernet1/0/1
port link-type trunk
port trunk permit vlan %vlan_num%
interface GigabitEthernet1/0/2
port link-type trunk
port trunk permit vlan %vlan_num%
interface GigabitEthernet1/0/17
port access vlan %vlan_num%
stp disable
stp edged-port enable
interface GigabitEthernet1/0/18
port access vlan %vlan_num%
stp disable
stp edged-port enable

Объединение портов Bridge-Aggregation

Агрегирование физических портов позволяет использовать группу как единый логический линк. Кроме избыточности и резервирования, на случай аварии, такая группа суммирует пропускную способность включенных портов.
H3C: Производительный коммутатор с пол пинка
На каждом коммутаторе необходимо создать логическую группу агрегирования:

interface Bridge-Aggregation %agg_num%
link-aggregation mode dynamic //используется например при соединении с Cisco

Для всех задействованых портов в группе необходимо указать соответствующую агрегацию:

interface GigabitEthernet %port_num% //перебрать также все включенные интерфейсы
port link-aggregation group %agg_num%

После установки привязки портов к соответствующим группам агрегирования можно установить опции для задействованного канала:

interface Bridge-Aggregation %agg_num%
port link-type trunk //может быть и access vlan_id
port trunk permit vlan %vlan_num%

Если агрегация используется в MSTP то конфигурация дерева для узла примет вид (вместо блокировки физических портов состояние будет меняться для логических линков):

display stp brief
 MSTID   Port Role      STP  State      Protection 
  0 Bridge­Aggregation1 ALTE DISCARDING    NONE
  0 Bridge­Aggregation2 ROOT FORWARDING    NONE
Рекомендовано к прочтению:

  1. Configuration Guide — www.h3c.com/portal/Technical_Support___Documents/Technical_Documents/Switches/H3C_S5120_Series_Switches/Configuration/Operation_Manual/H3C_S5120-SI_CG-Release_1101-6W105/
  2. Command Reference — www.h3c.com/portal/Technical_Support___Documents/Technical_Documents/Switches/H3C_S5120_Series_Switches/Command/Command/H3C_S5120-SI_CR-Release_1101-6W105/

Автор: belgak

Источник

Поделиться

* - обязательные к заполнению поля