Типы областей OSPF

в 8:34, , рубрики: Cisco, ospf, маршрутизация, метки: , ,

Введение

Добрый день!

В этой статье я хотел бы рассказать о типах областей OSPF. Статьи по настройке OSPF с использованием областей как-то здесь мне уже попадались. Я же хочу рассмотреть, чем эти типы областей отличаются друг от друга: normal, stub, totally stubby, NSSA, totally NSSA. Итак, начнем.

OSPF относится к link state категории протоколов динамической маршрутизации. Это значит, что роутеры не передают друг другу в качестве обновлений информацию о сетях. Вместо этого роутеры обмениваются информацией о состоянии своих интерфейсов или объявлениями о состоянии канала. Для этого используются специальные типы пакетов, которые называются LSA – Link State Advertisement. Данные сообщения бывают разных типов. Разобравшись в типах LSA, вы легко разберетесь чем отличаются между собой разные типы областей OSPF друг от друга.

Для примера я буду использовать следующую топологию:

image

Базовое конфигурирование

Все роутеры Cisco. Сначала сконфигурируем OSPF в Area 0 (синяя). В этой области три роутера: ABR, R1AR0, R2AR0. Между R1AR0 и ABR соединение точка-точка (10.1.1.0/24), между R1AR0 и R2AR0 – Ethernet (10.2.2.0/24). На R2AR0 созданы loopback интерфейсы с адресами 10.10.x.0/32.

R1AR0:

hostname R1AR0
!
int s0/0
 no shut
 ip address 10.1.1.1 255.255.255.0
!
int fa1/0
 no shut
 ip address 10.2.2.1 255.255.255.0
!
router ospf 1
 router-id 1.1.1.1
 network 10.0.0.0 0.255.255.255 area 0
 
Простая конфигурация. Добавляем интерфейсы в OSPF. Задаем Router-ID, только для того, чтобы проще было определять принадлежность LSA к конкретному роутеру.

R2AR1:

hostname R2AR0
!
int f0/0
 no shut
 description CONNECTION TO R1AR1
 ip address 10.2.2.2 255.255.255.0
!
int s0/0
 no shut
 description CONNECTION TO RIPRTR
 ip address 10.3.3.1 255.255.255.0
!
int loop 0
 ip address 10.10.0.1 255.255.255.255
!
int loop 1
 ip address 10.10.1.1 255.255.255.255
!
int loop 2
 ip address 10.10.2.1 255.255.255.255
!
int loop 3
 ip address 10.10.3.1 255.255.255.255
!
router ospf 1
 router-id 2.2.2.2
 network 10.2.2.2 0.0.0.0 area 0
 network 10.10.0.0 0.0.255.255 area 0
 
Аналогичная конфигурация. Обратите внимание, что интерфейс s0/0 не участвует в работе OSPF. Позже он будет работать с RIP.

ABR:

hostname ABR
!
int s0/0
 no shut
 ip address 10.1.1.2 255.255.255.0
!
int s0/1
 no shut
 ip address 192.168.1.1 255.255.255.0
!
router ospf 1
 router-id 1.1.2.2
 network 10.0.0.0 0.255.255.255 area 0
 
Пока в OSPF включаем только интерфейс s0/0 с адресом 10.1.1.2.

LSA 1 и 2 типа

Теперь давайте глянем на таблицы маршрутизации и на то, что хранится в базе LSDB.
R1AR0:

R1AR0#sh ip ro
     10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
O       10.10.1.1/32 [110/2] via 10.2.2.2, 00:07:47, FastEthernet1/0
O       10.10.0.1/32 [110/2] via 10.2.2.2, 00:07:47, FastEthernet1/0
O       10.10.3.1/32 [110/2] via 10.2.2.2, 00:07:47, FastEthernet1/0
O       10.10.2.1/32 [110/2] via 10.2.2.2, 00:07:47, FastEthernet1/0
C       10.2.2.0/24 is directly connected, FastEthernet1/0
C       10.1.1.0/24 is directly connected, Serial0/0
R1AR0#sh ip ospf database database-summary
 
            OSPF Router with ID (10.2.2.1) (Process ID 1)
 
Area 0 database summary
  LSA Type      Count    Delete   Maxage
  Router             3        0        0
  Network           1        0        0
  Summary Net    0        0        0
  Summary ASBR  0        0        0
  Type-7 Ext       0        0        0
    Prefixes redistributed in Type-7  0
  Opaque Link      0        0        0
  Opaque Area     0        0        0
  Subtotal           4        0        0
 
Process 1 database summary
  LSA Type      Count    Delete   Maxage
  Router              3        0        0
  Network            1        0        0
  Summary Net     0        0        0
  Summary ASBR   0        0        0
  Type-7 Ext        0        0        0
  Opaque Link       0        0        0
  Opaque Area      0        0        0
  Type-5 Ext        0        0        0
      Prefixes redistributed in Type-5  0
  Opaque AS        0        0        0
  Total                4        0        0

 
В таблице маршрутизации мы видим маршруты, помеченные кодом «О» — OSPF. В базе LSDB мы видим, что общее количество LSA равно 4, как для Area 0, так и для процесса OSPF. В базе данных находится 3 – Router LSA (тип 1) и 1 – Network LSA (Тип 2).  Аналогичную картину в базе данных мы увидим и на остальных роутерах. Итак, что из себя представляют LSA указанных типов?

Router LSA (тип 1)

Этот тип LSA генерирует каждый роутер в области и выполняет флуд по области, но не за ее пределы.  В нашей области сейчас 3 роутера, соответственно в базе мы видим 3 Router LSA. Данный тип LSA представляет роутер и его интерфейсы. Давайте глянем на него подробнее:

R1AR0#sh ip ospf database router
 
            OSPF Router with ID (1.1.1.1) (Process ID 1)
 
                Router Link States (Area 0)
 
  LS age: 14
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 1.1.1.1
  Advertising Router: 1.1.1.1
  LS Seq Number: 80000001
  Checksum: 0xD17C
  Length: 60
  Number of Links: 3
 
    Link connected to: a Transit Network
     (Link ID) Designated Router address: 10.2.2.2
     (Link Data) Router Interface address: 10.2.2.1
      Number of TOS metrics: 0
       TOS 0 Metrics: 1
 
    Link connected to: another Router (point-to-point)
     (Link ID) Neighboring Router ID: 1.1.2.2
     (Link Data) Router Interface address: 10.1.1.1
      Number of TOS metrics: 0
       TOS 0 Metrics: 64
 
    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 10.1.1.0
     (Link Data) Network Mask: 255.255.255.0
      Number of TOS metrics: 0
       TOS 0 Metrics: 64
 
 
  LS age: 18
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 1.1.2.2
  Advertising Router: 1.1.2.2
  LS Seq Number: 80000003
  Checksum: 0x81F6
  Length: 48
  Number of Links: 2
 
    Link connected to: another Router (point-to-point)
     (Link ID) Neighboring Router ID: 1.1.1.1
     (Link Data) Router Interface address: 10.1.1.2
      Number of TOS metrics: 0
       TOS 0 Metrics: 64
 
    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 10.1.1.0
     (Link Data) Network Mask: 255.255.255.0
      Number of TOS metrics: 0
       TOS 0 Metrics: 64
 
 
  Adv Router is not-reachable
  LS age: 131
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 2.2.2.2
  Advertising Router: 2.2.2.2
  LS Seq Number: 80000006
  Checksum: 0x193E
  Length: 84
  Number of Links: 5
 
    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 10.10.0.1
     (Link Data) Network Mask: 255.255.255.255
      Number of TOS metrics: 0
       TOS 0 Metrics: 1
 
    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 10.10.1.1
     (Link Data) Network Mask: 255.255.255.255
      Number of TOS metrics: 0
       TOS 0 Metrics: 1
 
    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 10.10.2.1
     (Link Data) Network Mask: 255.255.255.255
      Number of TOS metrics: 0
       TOS 0 Metrics: 1
 
    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 10.10.3.1
     (Link Data) Network Mask: 255.255.255.255
      Number of TOS metrics: 0
       TOS 0 Metrics: 1
 
    Link connected to: a Transit Network
     (Link ID) Designated Router address: 10.2.2.1
     (Link Data) Router Interface address: 10.2.2.2
      Number of TOS metrics: 0
       TOS 0 Metrics: 10
 
 
 
 
 
 
 
 
 
Это LSA данного роутера: Router-id 1.1.1.1.
 
 
 
 
 
У этого роутера есть перечисленные интерфейсы.
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Следующий роутер: 1.1.2.2 (ABR).
 
 
 
 
 
 
 
И его интерфейсы.
 
 
 
 
 
 
 
 
 
 
 
 
Последний роутер (R2AR0).
 
 
 
 
 
 
 
 
 
Его интерфейсы, в том числе куча loopback.
 

 
Давайте резюмируем. Router LSA (Тип 1):

  • Генерирует каждый роутер в области.
  • Содержат информацию о роутере (Router-ID) и данные о состоянии его интерфейсов.
  • Флуд по области, но не за ее пределы.

Network LSA (тип 2)

Второй тип LSA, который мы видим в нашей области – Network LSA. В области есть Ethernet-сегмент, к которому подключены 2 роутера (R1AR0 и R2AR0). Ethernet, Frame Relay, ATM – эти типы сетей относятся к сетям с множественным доступом: Broadcast MultiAccess (Ethernet) и Non Broadcast MultiAccess (NBMA). Т.е. к общей среде передачи данных подключено одновременно несколько роутеров и сеть обладает или нет возможностями широковещательной рассылки.  Если бы в такой сети все роутеры обменивались топологической информацией друг с другом, то это привело бы к рассылке большого количества копий LSA, каждый с каждым. Для предотвращения множественной рассылки копий в таких сетевых сегментах выбираются DR и BDR роутеры. Синхронизацию LSDB другие роутеры будут выполнять только с ними.
DR-роутер генерирует Network LSA для представления таких сетевых сегментов. По сути, Network LSA представляет собой транзитную сеть и все роутеры к ней подключенные:

R1AR0#sh ip ospf database network
 
            OSPF Router with ID (1.1.1.1) (Process ID 1)
 
                Net Link States (Area 0)
 
  Routing Bit Set on this LSA
  LS age: 1449
  Options: (No TOS-capability, DC)
  LS Type: Network Links
  Link State ID: 10.2.2.2 (address of Designated Router)
  Advertising Router: 2.2.2.2
  LS Seq Number: 80000001
  Checksum: 0x1501
  Length: 32
  Network Mask: /24
        Attached Router: 2.2.2.2
        Attached Router: 1.1.1.1
 
 
 
 
 
 
 
 
 
 
Идентификатор и адрес DR роутера.
 
 
 
Роутеры, подключенные к транзитной сети.

 
Резюмируем. Network LSA (Тип 2):

  • Генерирует DR роутер в области.
  • Содержат информацию о DR-роутере (Router-ID) и роутерах, которые подключены к сети с множественным доступом.
  • Флуд по области, но не за ее пределы.

Normal Area и Summary LSA (Тип 3)

Дизайн OSPF предполагает двухуровневую архитектуру. Есть магистральная область (Backbone, идентификатор 0.0.0.0) и остальные области, которые должны быть подключены к магистральной. Связи между областями осуществляют роутеры, интерфейсы которых подключены к двум и более областям. В терминологии OSPF они называются Area Border Router (ABR). Магистральную область мы настроили. Теперь давайте настроим еще одну область:
ABR:

hostname ABR
!
router ospf 1
 network 192.168.1.1 0.0.0.0 area 1
 
Добавляем второй интерфейс и подключаем его к Area 1.

 
R1AR2:

hostname R1AR1
!
int s0/1
 description CONNECTION TO ASBR
 no shut
 ip address 192.168.2.1 255.255.255.0
!
int s0/0
 description CONNECTION TO ABR
 no shut
 ip address 192.168.1.2 255.255.255.0
!
router ospf 1
 router-id 3.3.3.3
 network 192.168.0.0 0.0.255.255 area 1
 
Все интерфейсы в Area 1.

 
ASBR:

hostname ASBR
!
int s0/0
 description CONNECTION TO R1AR1
 no shut
 ip address 192.168.2.2 255.255.255.0
!
router ospf 1
 router-id 4.4.4.4
 network 192.168.0.0 0.0.255.255 area 1
!
ip route 1.0.0.0 255.0.0.0 null0
ip route 2.0.0.0 255.0.0.0 null0
ip route 3.0.0.0 255.0.0.0 null0
!
 
Аналогичная конфигурация. На статические маршруты пока не обращаем внимания, они понадобятся позднее.

 
Теперь посмотрим, как изменилась топологическая база и таблица маршрутизации. По прежнему выполним нужные команды на R1AR0 (Area 0):

     10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
O       10.10.1.1/32 [110/2] via 10.2.2.2, 00:08:10, FastEthernet1/0
O       10.10.0.1/32 [110/2] via 10.2.2.2, 00:08:10, FastEthernet1/0
O       10.10.3.1/32 [110/2] via 10.2.2.2, 00:08:10, FastEthernet1/0
O       10.10.2.1/32 [110/2] via 10.2.2.2, 00:08:10, FastEthernet1/0
C       10.2.2.0/24 is directly connected, FastEthernet1/0
C       10.1.1.0/24 is directly connected, Serial0/0
O IA 192.168.1.0/24 [110/128] via 10.1.1.2, 00:08:10, Serial0/0
O IA 192.168.2.0/24 [110/192] via 10.1.1.2, 00:07:22, Serial0/0
R1AR0#sh ip ospf database database-summary
 
            OSPF Router with ID (1.1.1.1) (Process ID 1)
 
Area 0 database summary
  LSA Type      Count    Delete   Maxage
  Router              3        0        0
  Network            1        0        0
  Summary Net     2        0        0
  Summary ASBR   0        0        0
  Type-7 Ext        0        0        0
    Prefixes redistributed in Type-7  0
  Opaque Link       0        0        0
  Opaque Area      0        0        0
  Subtotal            6        0        0
 
Process 1 database summary
  LSA Type      Count    Delete   Maxage
  Router              3        0        0
  Network            1        0        0
  Summary Net     2        0        0
  Summary ASBR   0        0        0
  Type-7 Ext        0        0        0
  Opaque Link       0        0        0
  Opaque Area      0        0        0
  Type-5 Ext        0        0        0
      Prefixes redistributed in Type-5  0
  Opaque AS        0        0        0
  Total                6        0        0

 
В таблице маршрутизации появились маршруты помеченные кодом «O IA» — маршруты OSPF из других областей. А в топологической базе добавилось два Summary LSA (тип 3). Сколько сетей передается из Area 1 в Area 0? Правильно – две: 192.168.1.1 и 192.168.2.0. Сколько Summary LSA? Тоже две.
Давайте посмотрим на детали:

R1AR0#sh ip ospf database summary
 
            OSPF Router with ID (1.1.1.1) (Process ID 1)
 
                Summary Net Link States (Area 0)
 
  Routing Bit Set on this LSA
  LS age: 919
  Options: (No TOS-capability, DC, Upward)
  LS Type: Summary Links(Network)
  Link State ID: 192.168.1.0 (summary Network Number)
  Advertising Router: 1.1.2.2
  LS Seq Number: 80000001
  Checksum: 0x2468
  Length: 28
  Network Mask: /24
        TOS: 0  Metric: 64
 
  Routing Bit Set on this LSA
  LS age: 868
  Options: (No TOS-capability, DC, Upward)
  LS Type: Summary Links(Network)
  Link State ID: 192.168.2.0 (summary Network Number)
  Advertising Router: 1.1.2.2
  LS Seq Number: 80000001
  Checksum: 0x9BAF
  Length: 28
  Network Mask: /24
        TOS: 0  Metric: 128
 
 
 
 
 
 
 
 
Адрес сети и идентификатор роутера, который ее анонсировал.
 

 
Давайте выполним те же команды, но на роутере из другой области:

ASBR#sh ip ro
S    1.0.0.0/8 is directly connected, Null0
S    2.0.0.0/8 is directly connected, Null0
S    3.0.0.0/8 is directly connected, Null0
     10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
O IA    10.10.1.1/32 [110/194] via 192.168.2.1, 00:08:12, Serial0/0
O IA    10.10.0.1/32 [110/194] via 192.168.2.1, 00:08:12, Serial0/0
O IA    10.10.3.1/32 [110/194] via 192.168.2.1, 00:08:12, Serial0/0
O IA    10.10.2.1/32 [110/194] via 192.168.2.1, 00:08:12, Serial0/0
O IA    10.2.2.0/24 [110/193] via 192.168.2.1, 00:08:15, Serial0/0
O IA    10.1.1.0/24 [110/192] via 192.168.2.1, 00:08:15, Serial0/0
O    192.168.1.0/24 [110/128] via 192.168.2.1, 00:08:15, Serial0/0
C    192.168.2.0/24 is directly connected, Serial0/0
 
ASBR#sh ip ospf database database-summary
 
            OSPF Router with ID (4.4.4.4) (Process ID 1)
 
Area 1 database summary
  LSA Type      Count    Delete   Maxage
  Router               3        0        0
  Network             0        0        0
  Summary Net      6        0        0
  Summary ASBR    0        0        0
  Type-7 Ext         0        0        0
    Prefixes redistributed in Type-7  0
  Opaque Link        0        0        0
  Opaque Area       0        0        0
  Subtotal             9        0        0
 
Process 1 database summary
  LSA Type      Count    Delete   Maxage
  Router                3        0        0
  Network              0        0        0
  Summary Net       6        0        0
  Summary ASBR     0        0        0
  Type-7 Ext          0        0        0
  Opaque Link         0        0        0
  Opaque Area        0        0        0
  Type-5 Ext          0        0        0
      Prefixes redistributed in Type-5  0
  Opaque AS          0        0        0
  Total                  9        0        0
 
ASBR#sh ip ospf database summary
 
            OSPF Router with ID (4.4.4.4) (Process ID 1)
 
                Summary Net Link States (Area 1)
 
  Routing Bit Set on this LSA
  LS age: 1021
  Options: (No TOS-capability, DC, Upward)
  LS Type: Summary Links(Network)
  Link State ID: 10.1.1.0 (summary Network Number)
  Advertising Router: 1.1.2.2
  LS Seq Number: 80000002
  Checksum: 0x45A4
  Length: 28
  Network Mask: /24
        TOS: 0  Metric: 64
 
  Routing Bit Set on this LSA
  LS age: 1021
  Options: (No TOS-capability, DC, Upward)
  LS Type: Summary Links(Network)
  Link State ID: 10.2.2.0 (summary Network Number)
  Advertising Router: 1.1.2.2
  LS Seq Number: 80000002
  Checksum: 0x38AE
  Length: 28
  Network Mask: /24
        TOS: 0  Metric: 65
 
  Routing Bit Set on this LSA
  LS age: 1023
  Options: (No TOS-capability, DC, Upward)
  LS Type: Summary Links(Network)
  Link State ID: 10.10.0.1 (summary Network Number)
  Advertising Router: 1.1.2.2
  LS Seq Number: 80000002
  Checksum: 0xEDF0
  Length: 28
  Network Mask: /32
        TOS: 0  Metric: 66
 
  Routing Bit Set on this LSA
  LS age: 1024
  Options: (No TOS-capability, DC, Upward)
  LS Type: Summary Links(Network)
  Link State ID: 10.10.1.1 (summary Network Number)
  Advertising Router: 1.1.2.2
  LS Seq Number: 80000002
  Checksum: 0xE2FA
  Length: 28
  Network Mask: /32
        TOS: 0  Metric: 66
 
  Routing Bit Set on this LSA
  LS age: 1025
  Options: (No TOS-capability, DC, Upward)
  LS Type: Summary Links(Network)
  Link State ID: 10.10.2.1 (summary Network Number)
  Advertising Router: 1.1.2.2
  LS Seq Number: 80000002
  Checksum: 0xD705
  Length: 28
  Network Mask: /32
        TOS: 0  Metric: 66
 
  Routing Bit Set on this LSA
  LS age: 1027
  Options: (No TOS-capability, DC, Upward)
  LS Type: Summary Links(Network)
  Link State ID: 10.10.3.1 (summary Network Number)
  Advertising Router: 1.1.2.2
  LS Seq Number: 80000002
  Checksum: 0xCC0F
  Length: 28
  Network Mask: /32
        TOS: 0  Metric: 66
 

 
Количество сетей, полученных из другой области и количество Summary LSA тоже совпадают. Так же обратите внимание, что все Summary LSA анонсировал единственный роутер – ABR, т.е. граничный маршрутизатор области, связывающий их друг с другом.
В чем смысл Summary LSA? Давайте вспомним, как работает OSPF:

  1. Роутеры дружат.
  2. Синхронизируют LSDB.
  3. На каждом роутере отрабатывает Dijkstra, который просчитывает все возможные альтернативы до всех сетей.
  4. Из них выбирает по метрике лучшие маршруты и устанавливает их в таблицу маршрутизации.

Обычному роутеру, например, из области 1, так ли необходим третий шаг в отношении сетей из других областей? Зачем ему подробности о топологии других областей? Все равно вход в другие области через граничный роутер (ABR). Поэтому ABR-роутер конвертирует, полученные Router и Network LSA в Summary LSA. Т.е. он представляет сети из противоположной области, как бы подключенными к нему. Area 0 видит все сети из Area 1 подключенными к ABR и наоборот. Оптимизируется производительность, уменьшается количество флуда. Обращаю внимание, что как такового суммирования в привычном понимании не выполняется. Просто вместо детальных Router и Network LSA передается более общий Summary LSA.
Резюмируем. Summary LSA (Тип 3):

  • Генерирует ABR роутер.
  • Конвертирует Router и Network LSA в Summary LSA.
  • Флуд в соседние области.

External LSA (тип 5) и тупиковые (Stub) области

External LSA

Теперь к Area 0 подключим внешний домен маршрутизации, в моем случае, работающий под управление протокола RIP и настроим передачу маршрутов из RIP в OSPF.
R2AR1:

hostname R2AR0
!
router rip
 version 2
 network 10.0.0.0
!
router ospf 1
 redistribute rip subnets
 
Включаем RIP.
 
 
 
 
 
Настраиваем передачу маршрутов RIP в OSPF.

 
RTRRIP:

hostname RIPRTR
!
int s0/0
 no shut
 description CONNECTION TO R2AR0
 ip address 10.3.3.2 255.255.255.0
!
router rip
 version 2
 no auto-summary
 network 10.0.0.0
 network 172.20.0.0
!
int loop 0
 ip address 172.20.0.1 255.255.255.0
!
int loop 1
 ip address 172.20.1.1 255.255.255.0
!
int loop 2
 ip address 172.20.2.1 255.255.255.0
!
int loop 3
 ip address 172.20.3.1 255.255.255.0
 
Базовая конфигурация.
Включаем RIP.
 
 
 
 
 

 
Как обычно, посмотрим на таблицу маршрутизации и на LSDB на роутере из 0 области:

R1AR0#sh ip ro
     172.20.0.0/16 is variably subnetted, 5 subnets, 2 masks
O E2    172.20.0.0/24 [110/20] via 10.2.2.2, 00:00:17, FastEthernet1/0
O E2    172.20.0.0/16 [110/20] via 10.2.2.2, 00:04:46, FastEthernet1/0
O E2    172.20.1.0/24 [110/20] via 10.2.2.2, 00:00:17, FastEthernet1/0
O E2    172.20.2.0/24 [110/20] via 10.2.2.2, 00:00:17, FastEthernet1/0
O E2    172.20.3.0/24 [110/20] via 10.2.2.2, 00:00:17, FastEthernet1/0
     10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
O       10.10.1.1/32 [110/2] via 10.2.2.2, 00:04:47, FastEthernet1/0
O       10.10.0.1/32 [110/2] via 10.2.2.2, 00:04:47, FastEthernet1/0
O       10.10.3.1/32 [110/2] via 10.2.2.2, 00:04:47, FastEthernet1/0
O       10.10.2.1/32 [110/2] via 10.2.2.2, 00:04:47, FastEthernet1/0
O E2    10.3.3.0/24 [110/20] via 10.2.2.2, 00:04:47, FastEthernet1/0
C       10.2.2.0/24 is directly connected, FastEthernet1/0
C       10.1.1.0/24 is directly connected, Serial0/0
O IA 192.168.1.0/24 [110/128] via 10.1.1.2, 00:04:49, Serial0/0
O IA 192.168.2.0/24 [110/192] via 10.1.1.2, 00:04:49, Serial0/0
 
R1AR0#sh ip ospf database database-summary
 
            OSPF Router with ID (1.1.1.1) (Process ID 1)
 
Area 0 database summary
  LSA Type      Count    Delete   Maxage
  Router              3        0        0
  Network            1        0        0
  Summary Net     2        0        0
  Summary ASBR   0        0        0
  Type-7 Ext        0        0        0
    Prefixes redistributed in Type-7  0
  Opaque Link       0        0        0
  Opaque Area      0        0        0
  Subtotal            6        0        0
 
Process 1 database summary
  LSA Type      Count    Delete   Maxage
  Router              3        0        0
  Network            1        0        0
  Summary Net     2        0        0
  Summary ASBR   0        0        0
  Type-7 Ext        0        0        0
  Opaque Link       0        0        0
  Opaque Area      0        0        0
  Type-5 Ext        6        0        0
      Prefixes redistributed in Type-5  0
  Opaque AS        0        0        0
  Total               12       0        0
 

 
То же на роутере из области 1:

R1AR1#sh ip ro
 
Gateway of last resort is not set
 
     172.20.0.0/16 is variably subnetted, 5 subnets, 2 masks
O E2    172.20.0.0/24 [110/20] via 192.168.1.1, 00:02:28, Serial0/0
O E2    172.20.0.0/16 [110/20] via 192.168.1.1, 00:06:52, Serial0/0
O E2    172.20.1.0/24 [110/20] via 192.168.1.1, 00:02:28, Serial0/0
O E2    172.20.2.0/24 [110/20] via 192.168.1.1, 00:02:28, Serial0/0
O E2    172.20.3.0/24 [110/20] via 192.168.1.1, 00:02:27, Serial0/0
     10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
O IA    10.10.1.1/32 [110/130] via 192.168.1.1, 00:45:40, Serial0/0
O IA    10.10.0.1/32 [110/130] via 192.168.1.1, 00:45:40, Serial0/0
O IA    10.10.3.1/32 [110/130] via 192.168.1.1, 00:45:40, Serial0/0
O IA    10.10.2.1/32 [110/130] via 192.168.1.1, 00:45:40, Serial0/0
O E2    10.3.3.0/24 [110/20] via 192.168.1.1, 00:06:54, Serial0/0
O IA    10.2.2.0/24 [110/129] via 192.168.1.1, 00:45:40, Serial0/0
O IA    10.1.1.0/24 [110/128] via 192.168.1.1, 00:45:41, Serial0/0
C    192.168.1.0/24 is directly connected, Serial0/0
C    192.168.2.0/24 is directly connected, Serial0/1
 
R1AR1#sh ip ospf database database-summary
 
            OSPF Router with ID (3.3.3.3) (Process ID 1)
 
Area 1 database summary
  LSA Type      Count    Delete   Maxage
  Router               3        0        0
  Network             0        0        0
  Summary Net      6        0        0
  Summary ASBR    0        0        0
  Type-7 Ext         3        0        0
    Prefixes redistributed in Type-7  0
  Opaque Link        0        0        0
  Opaque Area       0        0        0
  Subtotal            12       0        0
 
Process 1 database summary
  LSA Type      Count    Delete   Maxage
  Router               3        0        0
  Network             0        0        0
  Summary Net      6        0        0
  Summary ASBR    0        0        0
  Type-7 Ext         3        0        0
  Opaque Link        0        0        0
  Opaque Area       0        0        0
  Type-5 Ext         0        0        0
      Prefixes redistributed in Type-5  0
  Opaque AS         0        0        0
  Total                12       0        0
 

 
На обоих роутерах появились в таблице маршруты, помеченные «O E2», а в топологической базе увеличился счетчик Type-5 Ext LSA.
Детальная информация:

R1AR1#sh ip ospf database external
 
            OSPF Router with ID (3.3.3.3) (Process ID 1)
 
                Type-5 AS External Link States
 
  Routing Bit Set on this LSA
  LS age: 1215
  Options: (No TOS-capability, DC)
  LS Type: AS External Link
 
  Link State ID: 10.3.3.0 (External Network Number )
  Advertising Router: 2.2.2.2
  LS Seq Number: 80000001
  Checksum: 0xE3A4
  Length: 36
  Network Mask: /24
        Metric Type: 2 (Larger than any link state path)
        TOS: 0
        Metric: 20
        Forward Address: 0.0.0.0
        External Route Tag: 0
 
  Routing Bit Set on this LSA
  LS age: 941
  Options: (No TOS-capability, DC)
  LS Type: AS External Link
  Link State ID: 172.20.0.255 (External Network Number )
  Advertising Router: 2.2.2.2
  LS Seq Number: 80000001
  Checksum: 0xF5E1
  Length: 36
  Network Mask: /24
        Metric Type: 2 (Larger than any link state path)
        TOS: 0
        Metric: 20
        Forward Address: 0.0.0.0
        External Route Tag: 0

 
C External LSA (тип 5) все просто. Их генерирует ASBR-роутер (роутер, подключенный к внешнему домену маршрутизации и выполняющий передачу «чужих» маршрутов в OSPF) для представления внешних маршрутов, которые он передает в OSPF. Флуд по всем областям.
Резюмируем. External LSA (тип 5):

  • Генерирует ASBR.
  • Представляет с их помощью «чужие» сети.
  • Флуд по всем областям.

Stub и Totally Stubby области

Наконец-то добрались до специальных типов областей J. Давайте подведем небольшие итоги:

Тип LSA Кто создает? Границы флуда
Router (1) Все Область
Network (2) DR Область
Summary (3) ABR Соседние области
External (5) ASBR Все области

 
Теперь еще раз посмотрим на таблицу маршрутизации обычного роутера из Area 1:

R1AR1#sh ip ro    
172.20.0.0/24 is subnetted, 4 subnets
O E2    172.20.0.0 [110/20] via 192.168.1.1, 00:21:00, Serial0/0
O E2    172.20.1.0 [110/20] via 192.168.1.1, 00:21:00, Serial0/0
O E2    172.20.2.0 [110/20] via 192.168.1.1, 00:21:00, Serial0/0
O E2    172.20.3.0 [110/20] via 192.168.1.1, 00:21:00, Serial0/0
     10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
O IA    10.10.1.1/32 [110/130] via 192.168.1.1, 01:04:10, Serial0/0
O IA    10.10.0.1/32 [110/130] via 192.168.1.1, 01:04:10, Serial0/0
O IA    10.10.3.1/32 [110/130] via 192.168.1.1, 01:04:13, Serial0/0
O IA    10.10.2.1/32 [110/130] via 192.168.1.1, 01:04:13, Serial0/0
O E2    10.3.3.0/24 [110/20] via 192.168.1.1, 00:25:27, Serial0/0
O IA    10.2.2.0/24 [110/129] via 192.168.1.1, 01:04:13, Serial0/0
O IA    10.1.1.0/24 [110/128] via 192.168.1.1, 01:04:13, Serial0/0
C    192.168.1.0/24 is directly connected, Serial0/0
C    192.168.2.0/24 is directly connected, Serial0/1
 
 
 
 
 
External
 
Summary

Теперь сделаем эту область тупиковой (Stub). Для этого дадим следующую команду на ABR, R1AR0, ASBR:

router ospf 1
 area 1 stub

Команда должна быть выполнена на всех роутерах из области 1. Параметр настраивается на всех роутерах, так как он влияет на формирование отношений смежности.
Теперь посмотрим на таблицу маршрутизации:

R1AR1(config-router)#do sh ip ro
 
Gateway of last resort is 192.168.1.1 to network 0.0.0.0
 
     10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
O IA    10.10.1.1/32 [110/130] via 192.168.1.1, 00:01:24, Serial0/0
O IA    10.10.0.1/32 [110/130] via 192.168.1.1, 00:01:24, Serial0/0
O IA    10.10.3.1/32 [110/130] via 192.168.1.1, 00:01:24, Serial0/0
O IA    10.10.2.1/32 [110/130] via 192.168.1.1, 00:01:24, Serial0/0
O IA    10.2.2.0/24 [110/129] via 192.168.1.1, 00:01:24, Serial0/0
O IA    10.1.1.0/24 [110/128] via 192.168.1.1, 00:01:24, Serial0/0
C    192.168.1.0/24 is directly connected, Serial0/0
C    192.168.2.0/24 is directly connected, Serial0/1
O*IA 0.0.0.0/0 [110/65] via 192.168.1.1, 00:01:26, Serial0/0
 

Обратите внимание, что все внешние (External LSA) маршруты пропали, а вместо них появился маршрут по умолчанию (Summary LSA). Т.е. для тупиковой области ABR-роутер конвертирует все External LSA в единственный Summary LSA 0.0.0.0/0. При этом внутренние OSPF маршруты из других областей передаются, как обычно. Тупиковая область предназначена для снижения трафика обновлений. Сделав область тупиковой, вы как бы сообщаете все роутерам в этой области, что весь внешний мир (не OSPF) за ABR. Хождение External LSA в тупиковых областях запрещено.
Что такое Totally Stubby область? Это модификация тупиковой области, выполненная компанией Cisco. Настраивается очень просто. На ABR-роутере (и только на нем) выполняется следующая команда:

router ospf 1
 area 1 stub no-summary

Посмотрим теперь на таблицу маршрутизации:

R1AR1(config-router)#do sh ip ro
C    192.168.1.0/24 is directly connected, Serial0/0
C    192.168.2.0/24 is directly connected, Serial0/1
O*IA 0.0.0.0/0 [110/65] via 192.168.1.1, 00:00:58, Serial0/0
 

Как видите, теперь не только External, но и Summary LSA были преобразованы в единственный Summary LSA 0.0.0.0/0. No-summary – фильтруем Summary LSA.
Резюмируем:

  • Для Stub области ABR-роутер конвертирует External LSA в Summary LSA 0.0.0.0/0.
  • Для Stub области ABR-роутер конвертирует External и Summary LSA в Summary LSA 0.0.0.0/0.
  • Хождение External LSA в тупиковых областях запрещено.

NSSA области и NSSA LSA (тип 7)

Not so stubby area – не совсем тупиковая область. Хождение External LSA в тупиковых областях запрещено. Но представьте, что в такой области вам понадобилось передать в OSPF какой-то внешний маршрут. Например, пробросить статический маршрут до провайдера и т.д. В нашей топологии в Area 1 есть роутер ASBR на котором настроено несколько статических маршрутов. При попытке передать эти маршруты в OSPF мы получим сообщение об ошибке:

ASBR(config-router)#redistribute static subnets
Warning: Router is currently an ASBR while having only one area which is a stub area

Причина: хождение External LSA в тупиковых областях запрещено, и как следствие, в тупиковых областях запрещены ASBR. Что делать если ASBR и передача внешних маршрутов необходима? Для решения этой проблемы мы можем поменять тип области на NSSA. Данная область определяет специальный тип LSA – NSSA External (тип 7), который может существовать только в этой области. Т.е. вы получаете те же преимущества, связанные с контролем обновлений, что и для тупиковых областей, но при этом можете передавать внешние маршруты. В общем чистой воды обман: если External LSA запрещены, мы будем использовать NSSA External LSA, которые разрешены J. Конечно, не обман, а дополнительный RFC 3101 к OSPF.
Для настройки на всех роутерах в NSSA области выполняем команды:

router ospf 1
 no area 1 stub
 area 1 nssa

 
Для передачи маршрута по умолчанию, заменяющего External LSA необходимо на ABR роутере выполнить следующую команду:

router ospf 1
 area 1 nssa
 area 1 nssa default-information-originate

 
После этого можем передать внешние маршруты на ASBR роутере:

ASBR(config-router)#redistribute static subnets

 
Давайте посмотрим на таблицу маршрутизации и LSDB на роутерах из областей 0 и 1:

R1AR1#sh ip route
 
O N2 1.0.0.0/8 [110/20] via 192.168.2.2, 00:02:18, Serial0/1
O N2 2.0.0.0/8 [110/20] via 192.168.2.2, 00:02:18, Serial0/1
O N2 3.0.0.0/8 [110/20] via 192.168.2.2, 00:02:18, Serial0/1
 
 
 
Area 1 (NSSA)
R1AR1#sh ip ospf database database-summary
 
            OSPF Router with ID (3.3.3.3) (Process ID 1)
 
Area 1 database summary
  LSA Type      Count    Delete   Maxage
  Router               3        0        0
  Network             0        0        0
  Summary Net      6        0        0
  Summary ASBR    1        0        0
  Type-7 Ext         0        0        0
    Prefixes redistributed in Type-7  0
  Opaque Link        0        0        0
  Opaque Area       0        0        0
  Subtotal            10       0        0
 
Process 1 database summary
  LSA Type      Count    Delete   Maxage
  Router               3        0        0
  Network             0        0        0
  Summary Net      6        0        0
  Summary ASBR    1        0        0
  Type-7 Ext         0        0        0
  Opaque Link        0        0        0
  Opaque Area       0        0        0
  Type-5 Ext         5        0        0
      Prefixes redistributed in Type-5  0
  Opaque AS         0        0        0
  Total                15       0        0
 
 
 
 
Area 1 (NSSA)
R1AR0#sh ip ro
O E2 1.0.0.0/8 [110/20] via 10.1.1.2, 00:08:16, Serial0/0
O E2 2.0.0.0/8 [110/20] via 10.1.1.2, 00:08:16, Serial0/0
O E2 3.0.0.0/8 [110/20] via 10.1.1.2, 00:08:16, Serial0/0
 
Area 0 (Normal/Backbone)
R1AR0#sh ip ospf data database-summary
 
            OSPF Router with ID (1.1.1.1) (Process ID 1)
 
Area 0 database summary
  LSA Type      Count    Delete   Maxage
  Router               3        0        0
  Network             1        0        0
  Summary Net      2        0        0
  Summary ASBR    0        0        0
  Type-7 Ext         0        0        0
    Prefixes redistributed in Type-7  0
  Opaque Link        0        0        0
  Opaque Area       0        0        0
  Subtotal             6        0        0
 
Process 1 database summary
  LSA Type      Count    Delete   Maxage
  Router               3        0        0
  Network             1        0        0
  Summary Net      2        0        0
  Summary ASBR    0        0        0
  Type-7 Ext         0        0        0
  Opaque Link        0        0        0
  Opaque Area       0        0        0
  Type-5 Ext         8        0        0
      Prefixes redistributed in Type-5  0
  Opaque AS         0        0        0
  Total                14       0        0
 
 
 
 
Area 0 (Normal/Backbone)

NSSA External (тип 7) могут существовать только в NSSA области. Поэтому в этой области мы видим в таблице маршрутизации сети, помеченные кодом «N», а в LSDB присутствует данный тип LSA. На роутере из другой области мы видим обычные внешние маршруты, а также нет NSSA External LSA в базе. ABR-роутер выполняет конвертацию NSSA External (тип 7) в External (тип 5) и передает их в другие области.
Детальная информация по NSSA External:

R1AR1#sh ip ospf database nssa-external
 
            OSPF Router with ID (3.3.3.3) (Process ID 1)
 
                Type-7 AS External Link States (Area 1)
 
  Routing Bit Set on this LSA
  LS age: 882
  Options: (No TOS-capability, Type 7/5 translation, DC)
  LS Type: AS External Link
  Link State ID: 1.0.0.0 (External Network Number )
  Advertising Router: 4.4.4.4
  LS Seq Number: 80000001
  Checksum: 0x34E3
  Length: 36
  Network Mask: /8
        Metric Type: 2 (Larger than any link state path)
        TOS: 0
        Metric: 20
        Forward Address: 192.168.2.2
        External Route Tag: 0
 
 
 
 
 
 
 
 
 
 
 
Адрес сети и идентификатор роутера, анонсировавшего сеть.
 
 
 
 
 
 
Next-hop.
 

 
Последняя область: Totally NSSA. Расширение компании Cisco, аналогичное Totally Stub областям. В дополнение к блокированию External LSA, будет блокироваться и Summary LSA. Настраивается на ABR-роутере:

router ospf 1
 area 1 nssa default-information-originate no-summary
 

 

Заключение

Давайте подведем итоги.
Типы LSA:

Тип LSA Кто создает? Границы флуда
Router (1) Все Область
Network (2) DR Область
Summary (3) ABR Соседние области
External (5) ASBR Все области
NSSA External (7) ASBR Только NSSA область. На ABR конвертируется в External LSA и флуд в соседние области.

 
Типы областей:

Тип области  
Backbone
  • ID=0.0.0.0
  • Не может быть тупиковой
  • Все остальные области должны иметь соединение с backbone

Normal
  • Разрешены все LSA, кроме NSSA External (7)

Stub
  • Блокируются External LSA (5)
  • ABR конвертирует External LSA (5) в Summary LSA (3) 0.0.0.0/0

Totally Stubby
  • Модификация Cisco
  • Блокируются External LSA (5) и Summary LSA (3)
  • ABR конвертирует External LSA (5) и Summary LSA (3) в единственный Summary LSA (3) 0.0.0.0/0

NSSA
  • Блокируются External LSA (5)
  • ABR конвертирует External LSA (5) в Summary LSA (3) 0.0.0.0/0
  • Разрешены ASBR
  • Для передачи внешних маршрутов используется NSSA External LSA (7)
  • На ABR NSSA External LSA (7) конвертируется в External LSA (5) и передается в соседние области

Totally NSSA
  • Блокируются External LSA (5) и Summary LSA (3)
  • ABR конвертирует External LSA (5) и Summary LSA (3) в Summary LSA (3) 0.0.0.0/0
  • Разрешены ASBR
  • Для передачи внешних маршрутов используется NSSA External LSA (7)
  • На ABR NSSA External LSA (7) конвертируется в External LSA (5) и передается в соседние области

Спасибо за внимание. Надеюсь было интересно.

Автор: softline_education

Источник


* - обязательные к заполнению поля


https://ajax.googleapis.com/ajax/libs/jquery/3.4.1/jquery.min.js