Подготовка к CCIE лабе в домашних условиях

в 10:17, , рубрики: Cisco, diy или сделай сам, Сетевые технологии, метки: , ,

Начну пожалуй с краткого введения в Cisco CCIE экзамен.
История CCIE началась в 1993 году. Изначально экзамен состоял из двухдневной лабораторной работы, позднее его сократили до одного дня. Согласно Википедии меньше 3% Cisco специалистов удается стать счастливым обладателем CCIE сертификата.

Сам экзамен состоит из двух частей: письменной и лабораторной. На лабу дается 8 часов.
Существует несколько треков: «Маршрутизация и коммутация» (Routing and Switching); «Безопасность» (Security); «Провайдер услуг» (Service Provider); «Передача голоса» (Voice) и т.д.

image

Готовится к CCIE «Маршрутизация и коммутация» я начал около 2 лет назад. За плечами у меня на тот момент было около 6 лет опыта работы с сетевыми технологиями и успешно сданный CCNP экзамен.

После успешной сдачи письменного экзамена, я приступил готовится к лабе. Для подготовки я выбрал материалы ine.com, которые довольно популярны среди готовящихся к экзамену.

Есть несколько способов подготовки к лабораторной:
1. Приобретение всего необходимого оборудования, а это около 9 Cisco маршрутизаторов и 4 коммуникаторa. На ebay можно купить готовый набор за $2000 — $2500 плюс доставка.
Вот, что входит в стандартный набор:
2 x Cisco 2610XM
1 x Cisco 2611XM
3 x Cisco 1841
2 x Cisco 2501
1 x Cisco 2522/(or 2600 with NM-8A/S) (Frame Relay Switch)
1 x Cisco 2511 (Access Server)
2 x Cisco Catalyst 3550 Switch with EMI image
2 x Cisco Catalyst 3560 Switch with EMI Image

2. Второй вариант — это аренда оборудования. Где за почасовую оплату вы получаете доступ к необходимому оборудованию.
3. Третий вариант — это использование программ для эмуляции Cisco IOS, таких как Dynamips например.

У каждого из приведенных вариантов есть свои плюсы и минусы. Я остановился на третьем варианте, как на самом бюджетном. Для эмуляции маршрутизаторов Cisco я остановился на GNS3. GNS3 это графический интерфейс для Dynamips. Правда у GNS3 есть свой минус. Он не может полностью эмулировать Cisco Catalyst коммуникаторы. И это связано с тем, что Cisco использует ASIC процессоры для части функционала.

Поэтому мне пришлось использовать физические коммуникаторы, а маршрутизаторы эмулировать используя Dynamips.

Самая трудная, на мой взгляд, задача была — заставить реальные коммуникаторы общаться с виртуальными маршрутизаторами.

В моем распоряжении было 3 Cisco Catalyst 3750, заимствованные на работе и два б/у Cisco Catalyst 3550, купленных на ebay за $80 каждый.
Для эмуляции Cisco маршрутизаторов я использовал лаптоп Toshiba R700 со следующей конфигурацией: процессор Intel Core i3 2.27GHz с 4-мя гигабайтами памяти и Windows 7 Professional 64-bit операционной системой.

after2
Первое время приходилось настраивать все на месте. В дальнейшем я уже подключался по удаленному доступу.

ine topology
Топология INE выглядит следующим образом.

Чтобы подключить GNS3 маршрутизатор к физическому коммуникатору я решил использовать 802.1q trunk. Для этого необходимо, чтобы сетевая карта на лаптопе поддерживала VLAN теги.

Мой Тошиба R700 имел сетевую карту от Intel, которая поддерживала VLAN теги. Но для этого нужно было скачать и установить ANS Teaming Software от Intel. Пришлось потратить достаточно времени, прежде чем добиться желаемого результата.

image
Сетевой адаптер с множеством виртуальных адаптеров.

Один из Cisco 3750 я использовал как Breakout switch, т.е как связующее звено между GNS3 устройствами и четырьмя физическими коммуникаторами, которые необходимы непосредственно для лабы.

network connections
Breakout Switch

gns3design
Топология в GNS3.

Так выглядит конфигурация на порту к которому подключен лаптоп:

interface GigabitEthernet2/0/24
description *** TRUNK TO THE LAPTOP ***
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2-4094
switchport mode trunk
l2protocol-tunnel cdp
l2protocol-tunnel stp
l2protocol-tunnel vtp
no cdp enable
spanning-tree portfast

Так выглядит конфигурация порта к которому подключен один из физических коммуникаторов.

interface GigabitEthernet2/0/3
description *** VLAN105 TO THE SW1 ***
switchport access vlan 105
switchport mode dot1q-tunnel
l2protocol-tunnel cdp
l2protocol-tunnel stp
l2protocol-tunnel vtp
no cdp enable
spanning-tree portfast

Чтобы избежать лишней головной боли, я изменил значение MTU для всех сетевых адаптеров со стандартного 1500 на 1536 таким образом:

netsh interface ipv4 set subinterface «LAN101» mtu=1536 store=persistent

Кстати проверить текущий размер MTU на windows можно так:

netsh interface ipv4 show subinterface

Для подключения к каждому из физических концентраторов мне понадобился дополнительно USB хаб, с подключенным к нему необходимым количеством USB-to-Serial адаптеров. Цена на амазоне $19, но можно найти и дешевле.

ssh
Для работы с Cisco я использую SecureCRT.

Надеюсь вышеизложенный текст будет полезен кому-нибудь на нелегком пути к CCIE. Свою CCIE лабу я зарегистрировал на июль 2014. В следующий раз я постараюсь рассказать, что собой представляет экзамен на практике.

Автор: elmanr

Источник


* - обязательные к заполнению поля


https://ajax.googleapis.com/ajax/libs/jquery/3.4.1/jquery.min.js