Сотни миллионов пользователей Android могут столкнуться с серьёзной проблемой. Она касается работы огромного количества сайтов

в 15:49, , рубрики: Без рубрики

Компания Google уже достаточно давно не делится статистикой распространения разных версий Android, но мы и так знаем, что, в отличие от iOS, в случае Android на руках у пользователей очень много устройств, работающих под управлением достаточно старых версий операционной системы. 

Как сообщается, вскоре определённая часть таких пользователей может столкнуться с проблемами на различных сайтах.  

Всё дело в одном из корневых сертификатов Let's Encrypt. Let's Encrypt — один из ведущих мировых центров сертификации. Сертификаты этой группы используются примерно на 30% всех веб-доменов.  

Сотни миллионов пользователей Android могут столкнуться с серьёзной проблемой. Она касается работы огромного количества сайтов

Проблема в том, что 1 сентября следующего года заканчивает срок перекрёстного соглашения Let's Encrypt с IdenTrust, и продлевать его не будут. А это означает, что все браузеры и операционные системы без корневого сертификата Let's Encrypt больше не будут работать с сайтами и службами, использующими сертификаты группы. В оригинальном объявлении указано, что устройства под управлением Android 7.1.1 или более ранней версии входят в группу уязвимых. 

Таким образом, миллионы людей столкнутся с проблемами на очень большом количестве сайтов. Правда, есть частичный выход из ситуации, и называется он Firefox. Этот браузер использует собственное хранилище сертификатов, включающее тот самый корень ISRG.  

Что касается статистики, на апрель текущего года на долю Android 7.1 и более старых версий приходилось почти 34%, то есть очень и очень много. Сейчас доля этих версий явно немного ниже, но точно не в разы. 

Источник


* - обязательные к заполнению поля


https://ajax.googleapis.com/ajax/libs/jquery/3.4.1/jquery.min.js