Быстрая установка Mikrotik Cloud Hosted Router на хостинг с KVM

в 13:31, , рубрики: виртуализация, Серверное администрирование

В интернете много статей как раскатать крутейшую операционную систему от Mikrotik на vds/vps, но они все требуют очень много телодвижений.

А в этой статье не учтено, что kvm может иметь всего 256Мб оперативной памяти и образ не влезет в tmpfs. Для RouterOS этого вполне хватает в обучающих и других лёгких целях.

Я попробовал максимально упростить установку.

Для эксперимента я постарался найти самые дешёвые vps на kvm. Нашёл на free-www.ru от 65 рублей в Питере и 85 в Новосибирске (который и выбрал).

Быстрая установка Mikrotik Cloud Hosted Router на хостинг с KVM - 1

И neohost.net от $1 первый месяц (вроде как в Киеве).

Быстрая установка Mikrotik Cloud Hosted Router на хостинг с KVM - 2

Если есть дешевле, то прошу поделиться ссылкой. Ведь для демонстрации и обучения (ну и для vpn кому-то) сильно дорогой и не нужен.

На обоих выбрал CentOS 6 и 7. Думаю с другими версиями тоже будет всё ровно.

Авторизировался через ssh и набрал:

wget  -qO-  https://download2.mikrotik.com/routeros/6.41.4/chr-6.41.4.img.zip | gunzip | dd of=/dev/vda && sync && reboot

Ссылку на образ возьмите свежую с mikrotik.com/download
Мы скачиваем образ, на лету распаковываем и записываем на диск.

CHR при первой загрузке сам разметить весь диск.

Далее открываете VNC консоль (если на Вашем хостинге её нет, то попросите админа подключить на время), где уже загружен RouterOS (логин admin, пароль пустой) и добавляете адрес и маршрут по умолчанию

/ip address add address=XXX.XXX.XXX.55/24 interface=ether1
/ip router add gateway=XXX.XXX.XXX.1

где XXX.XXX.XXX.55 — выданный Вам ip адрес

Далее подключаетесь привычными для Вас средствами, например winbox.

Настоятельно рекомендую сразу создать своего пользователя и удалить «admin».

P.S.: У CHR триал составляет 60 дней

P.P.S.: Я слышал, что и назначение адреса можно автоматизировать, но в момент написания статьи не нашёл информации. Поделитесь опытом, если такое делали.

Автор: push

Источник

Поделиться

* - обязательные к заполнению поля